Welcome, guest | Sign In | My Account | Store | Cart

Notice! PyPM is being replaced with the ActiveState Platform, which enhances PyPM’s build and deploy capabilities. Create your free Platform account to download ActivePython or customize Python with the packages you require and get automatic updates.

Download
ActivePython
INSTALL>
pypm install yafowil.widget.autocomplete

How to install yafowil.widget.autocomplete

  1. Download and install ActivePython
  2. Open Command Prompt
  3. Type pypm install yafowil.widget.autocomplete
 Python 2.7Python 3.2Python 3.3
Windows (32-bit)
1.4.1 Available View build log
1.4 Available View build log
1.3 Available View build log
1.2 Available View build log
1.1 Available View build log
1.0.1 Available View build log
1.0 Available View build log
1.0-beta Available View build log
Windows (64-bit)
1.4
1.4.1Never BuiltWhy not?
1.4 Available View build log
1.3 Available View build log
1.2 Available View build log
1.1 Available View build log
1.0.1 Available View build log
1.0 Available View build log
1.0-beta Available View build log
Mac OS X (10.5+)
1.4.1 Available View build log
1.4 Available View build log
1.3 Available View build log
1.2 Available View build log
1.1 Available View build log
1.0.1 Available View build log
1.0 Available View build log
1.0-beta Available View build log
Linux (32-bit)
1.4.1 Available View build log
1.4 Available View build log
1.3 Available View build log
1.2 Available View build log
1.1 Available View build log
1.0.1 Available View build log
1.0 Available View build log
1.0-beta Available View build log
Linux (64-bit)
1.4.1 Available View build log
1.4 Available View build log
1.3 Available View build log
1.2 Available View build log
1.1 Available View build log
1.0.1 Available View build log
1.0 Available View build log
1.0-beta Available View build log
 
License
Simplified BSD
Dependencies
Lastest release
version 1.4.1 on Nov 20th, 2012

This is a autocomplete widget for for YAFOWIL - Yet Another Form WIdget Library.

It utilizes/integrates jquery.ui.autocomplete for/in YAFOWIL providing an autocomplete function on a text input.

Source Code

The sources are in a GIT DVCS with its main branches at github.

We'd be happy to see many forks and pull-requests to make YAFOWIL even better.

Contributors

History

1.4.1
  • use yafowil.utils.attr_value wherever possible. [rnix, 2012-10-25]
1.4
  • Add generic_required_extractor to extraction chain [rnix, 2012-07-25]
  • Adopt resource providing [rnix, 2012-06-12]
  • Remove example app [rnix, 2012-06-12]
1.3
  • Support JavaScript callback functions in source attribute [rnix, 2011-10-03]
  • register autocomplete binder in yafowil.widget.array hooks if installed [rnix, 2011-10-03]
  • register plan and depend on yafowil 1.3 [jensens, 2011-09-30]
1.2
  • adopt to yafowil 1.2 [jensens, 2011-09-20]
  • resource available in plain Zope2 [jensens, 2011-09-20]
1.1
  • adopt to yafowil 1.1 [rnix, 2011-07-08]
1.0.1
  • test coverage [rnix, 2011-05-07]
1.0
  • made it work [jensens, 2010-11-24]

License

Copyright (c) 2010-2012, BlueDynamics Alliance, Austria, Germany, Switzerland All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  • Neither the name of the BlueDynamics Alliance nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY BlueDynamics Alliance AS IS AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL BlueDynamics Alliance BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Subscribe to package updates

Last updated Nov 20th, 2012

Download Stats

Last month:8

What does the lock icon mean?

Builds marked with a lock icon are only available via PyPM to users with a current ActivePython Business Edition subscription.

Need custom builds or support?

ActivePython Enterprise Edition guarantees priority access to technical support, indemnification, expert consulting and quality-assured language builds.

Plan on re-distributing ActivePython?

Get re-distribution rights and eliminate legal risks with ActivePython OEM Edition.