| Store | Cart

Re: [Python-ideas] difflib.SequenceMatcher quick_ratio

From: Tal Einat <tale...@gmail.com>
Mon, 8 Jun 2015 18:15:29 +0300
On Mon, Jun 8, 2015 at 11:44 AM, Serhiy Storchaka <stor...@gmail.com> wrote:

> If such function will be added, I think it needs better name. E.g.> difflib.isclose(a, b, threshold).

Indeed, this is somewhat similar in concept to the recently-added
math.isclose() function, and could use a similar signature, i.e.:
difflib.SequenceMatcher.isclose(a, b, rel_tol=None, abs_tol=None).

However, the real issue here is whether this is important enough to be
included in the stdlib.

Are there any places in the stdlib where this would be useful?

Can anyone other than the OP confirm that they would find having this
in the stdlib particularly useful?

Why should this be in the stdlib vs. a recipe?

- Tal Einat
_______________________________________________
Python-ideas mailing list
Pyth...@python.org
https://mail.python.org/mailman/listinfo/python-ideas
Code of Conduct: http://python.org/psf/codeofconduct/

Recent Messages in this Thread
floyd Jun 08, 2015 07:56 am
Serhiy Storchaka Jun 08, 2015 08:44 am
Tal Einat Jun 08, 2015 03:15 pm
Matthias Bussonnier Jun 08, 2015 03:39 pm
Andrew Barnert via Python-ideas Jun 08, 2015 01:31 pm
Messages in this thread